Rechercher sur TLD Google
Favoris   Démarrage   Envoyer   Imprimer   Moteur TLD   RSS


Accueil > Actualités > Une vulnérabilité dans les drivers NVIDIA Unix

Une vulnérabilité dans les drivers NVIDIA Unix

Plusieurs vulnérabilités, référencées CVE-2014-8093, CVE-2014-8098 ou encore CVE-2014-8298, ont été identifiées ces dernières semaines dans le serveur X.Org qui assure la gestion de l'affichage sur un grand nombre de machines Unix. Ces failles de sécurité peuvent être exploitées pour faire crasher le serveur X voire pour exécuter du code malveillant.

NVIDIA vient de révéler que l'implémentation dans ses drivers graphiques de l'extension de rendu 3D GLX est vulnérable à cette faille. La marque indique être au courant de cette vulnérabilité depuis le début du mois d'octobre et annonce avoir désormais achevé la mise au point d'un correctif ce qui explique que l'ensemble des branches des drivers graphiques NVIDIA aient été mises à jour ces derniers jours.

Seuls les machines fonctionnant sous Linux, Solaris, FreeBSD, Chrome OS ou encore VMware ESX sont impactées. Cela ne concerne absolument pas les systèmes Windows et leurs drivers GeForce. NVIDIA précise par ailleurs ne pas être au courant à l'heure actuelle d'exploits permettant de tirer partie de cette faille dans ses drivers graphiques.

Le correctif de NVIDIA consiste à priori simplement en l'ajout de l'option -iglx pour le serveur X.Org afin de désactiver la création d'un contexte GLX indirect. Cette option est normalement désactivée par défaut dans les versions 1.17 et supérieures du serveur X. NVIDIA recommande également d'interdire, lorsque c'est possible, les connexions au serveur X depuis le réseau grâce à l'option -nolisten tcp.

Nous n'aborderons ci-dessous que les mises à jour correctives sorties ces derniers jours pour les distributions Linux. Pour les drivers des autres systèmes Unix voire pour le CUDA Toolkit SDK, consultez le site web de NVIDIA.

Drivers 346.22 beta pour GeForce 400/500/600/700/800/900/ION/Quadro K/NVS/SDI/GRID


Drivers 343.36 pour GeForce 400/500/600/700/800/900/ION/Quadro K/NVS/SDI/GRID


Drivers Legacy 340.65 pour GeForce 8/9/100/200/300/Quadro CX/FX/NVS/SDI


Drivers Legacy 304.125 pour GeForce 6/7/Quadro FX/NVS


Aucune mise à jour n'est prévue pour les drivers antérieurs à la branche R304 étant donné qu'ils ne sont plus supportés.

Actualité publiée par Julien Sambourg le jeudi 11 décembre 2014 à 10:25
Commenter cette actualité
Marque associée : NVIDIA
Catégories associées : Carte graphique Carte mère
Flux RSS des actualités TousLesDrivers.com



Actualités relatives
Annonces

Fichiers relatifs
Annonces

Dossiers relatifs
AMD Fusion for Gaming
AMD propose un nouvel outil logiciel pour optimiser les performances des configurations composées d'un processeur de la marque et d'une carte graphique ATI Radeon. Il s'agit de la première pierre au projet Fusion qui est si cher à AMD. Nous allons voir dans ce dossier dans quelle mesure cet utilitaire permet d'améliorer ou non les performances du système.

Les pilotes IDE VIA
Le constructeur VIA a souvent été critiqué pour la qualité de ses chipsets mais également pour celle de ses différents drivers. Il faut bien reconnaître qu'en ce qui concerne les pilotes IDE de VIA, c'est le flou le plus total pour l'utilisateur, essayons d'y voir plus clair.